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A Windows user profile defines the look and feel of the desktop environment configured for a particular user. It contains various settings
such as desktop colors, backgrounds, icon placement, and Windows Explorer settings. The default profile is a template profile that is
used when a user logs on to a Windows computer for the first time. The default profile can be customized by the image creator.

+ Windows 7 and Windows Server 2008

« Enable Desktop Background

* Create a Profile Setup Account

e Configure the User Profile for the Profile Setup Account

* Copy the Customized Profile to Default

« Clean the Registry for the Customized Profile

* Configure the User Account Picture (Optional)

Force the Desktop Background to Appear on Windows 7 & Windows Server 2008 (Optional)

. Wmdows XP and Windows Server 2003

« Create a Profile Configuration Account

* Copy the Customized Profile to "Default User"

« Clean up the Profile Configuration Account

Windows 7 and Windows Server 2008

Microsoft does not support copying profiles under Windows 7 and Windows Server 2008. The "Copy To" button is grayed out for all
profiles except the default profile. The only supported method is built into Sysprep and this method is itself very problematic. The
following steps are not supported or recommended by Microsoft but seem to work:

Enable Desktop Background

1. Download and edit the RDP file for your imaging reservation from the VCL website to allow desktop backgrounds or else you won’t
be able to change the desktop background color
a. Right-click on the .rdp file and select Edit
b. Click on the Experience tab
c. Select LAN (10 Mbps or higher)
d. Make sure the checkbox next to Desktop background is enabled
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sp Connectior

| Remote Desktop
»¢) Connection

| General I Display | Local Resources I Programs | Experience | Advanced

l Performance

Choose your connection speed to optimize peformance.

AR Hibps or higheri |

Allow the following:

. Desktop background I
. E“.Er:u'nt smu:u.:-t.hing

[¥] Desktop composition

Show window contents while dragging

[¥] Menu and window animation

[¥] visual styles

Persistent bitmap caching
Reconnect if the connection iz dropped

{4 Hide Options

e. Click on the General tab
f. Click Save
2. Login to the VCL reservation as Administrator
3. Configure Windows Explorer to show hidden and system file
Open Windows Explorer
Click Organize > Folder and search options
Select the View tab
Select the radio button next to Show hidden files, folders, and drives
Click OK

PaoT®

Create a Profile Setup Account

1. Create a new local user account named ProfileSetup (Note: the name does not matter but should be something that would not
match another string in the stock Windows registry. You will be searching the registry for the name of the user you use to
configure the profile. Using a unique name will make this easier.)

a. Open Control Panel > Add or remove user accounts
b. If there is already an account named ProfileSetup and you want to start over with a new account, delete the existing
account and then create a new one:
i. Click on the ProfileSetup user
ii. Click Delete the account
iii. Click Delete Files
iv. Click Delete Account

Click Create a new account

Enter the account name: ProfileSetup

Click the radio button next to Administrator

. Click Create Account

2. Set the password for the ProfileSetup account

a. Click on the ProfileSetup account
b. Click Create a password
c. Enter the password and click Create password

~0Qo0

Configure the User Profile for the Profile Setup Account

1. Logout as Administrator and login as ProfileSetup

If you intend to arrange the icons on the desktop, use a screen size of 1024x768 when logged in as ProfileSetup. This is
the default screen size that most users will use when they connect to VCL reservations. If you arrange the icons using a
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custom screen size, the icons most users see will be rearranged when they connect using the default size.

2. Customize the user profile while logged in as ProfileSetup account (configure the desktop background, arrange icons, etc). The
following tips are optional:
a. Download and run Autoruns. This free utility will show you all of the things that run when the computer boots, a user logs
in, etc. There are several things that can probably be disabled such as Windows Mail.

Copy the Customized Profile to Default

1. Logout as ProfileSetup and login as Administrator
2. Rename the ProfileSetup user profile folder to Default:
a. Open a Windows Explorer window and navigate to C:\Users
b. Rename the original default profile folder: C:\Users\Default -> C:\Users\DefaultOriginal
c. Rename the customized profile folder: C:\Users\ProfileSetup -> C:\Users\Default
Note: if you are unable to rename the ProfileSetup folder, reboot the computer, login as Administrator, and try again. Run
the following command from a command prompt to reboot the computer:
shutdown.exe -r -f -t 0
3. Copy the customized profile folder using the Windows profile copying utility:
Note: Windows 7 only allows its built-in profile copying utility to be used to copy the default profile, not profiles of other user
accounts. The profile you customized now resides in the default profile location (C:\Users\Default) so the utility can now be used
to make a copy of it.
. Open Control Panel > System and Security > System
. Click Advanced system settings on the left
. Click the Settings... button under User Profiles
Highlight Default Profile
. Click Copy To...
i. Copy profile to: C:\Users\DefaultCopy
ii. Click Change under Permitted to use
ii. Enter Everyone and click OK
iv. Click OK
4. Replace the original customized profile directory with the one created by the Windows profile copying utility
Note: C:\Users\Default contains the original customized profile. The same profile also resides in C:\Users\DefaultCopy. The
DefaultCopy folder is the one which has had the Windows profile copying utility transformations applied to it.
a. Open Windows Explorer
b. Delete the “C:\Users\Default folder
c. Rename the folder: C:\UsersDefaultCopy -> C:\Users\Default
5. Delete the ProfileSetup account:
Open Control Panel > Add or remove user accounts
Click on the ProfileSetup account
Click Delete the account
Click Delete Files
Click Delete Account

PoooTo

PaooTo

Clean the Registry for the Customized Profile

1. While logged in as Administrator
2. Run regedit.exe
3. Select the HKEY_USERS hive:
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File Edit View Favorites Help

4|8 Computer
-y HKEY_CLASSES_ROOT
; HEEY_CURREMT_USER

- ACHIME
E . HKEY_USERS
= L PHEEVCCURRENT_COMNFIG

Marne

ab) (Default)

Computer\HKEY_USERS

4. Click the File menu and select Load Hive:

File | Edit View Favorites Help

Import...
Export...

I Load Hive...

Unload Hive...

Connect Network Registry...

Disconnect Metwork Registry...
Print...

Exit

Ctrl+P

5. Browse to C:\Users\Default

6. Enter ntuser.dat in the File name: field (Note: this file is hidden so it normally is not displayed in the list of files)
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ﬁ Load Hiwve @
@\\:}v| ;% Local Disk (C:) » Users » Default » - | 4 | | Search Defauit jo) |
Organize « Mew folder = = .@.

A Favorites = Namel . . Date modified Type Sife
BE Desktop Desktop 1#13/2009 10:35 PR File folder
4. Dowenloads Docurnents TFLAF2009 1208 Ak File folder
=l Recent Places Downloads 14132009 10:35 PR File folder
3 Favorites 14132009 10:35 PRA - File folder
4 Libraries Links 113/2009 10:35 PR File folder
3 Documents Fusic 1#413/2009 10:35 PR File folder 3
ajp'- Mlusic Pictures FAL3F2009 1035 PR File folder
k=| Pictures = Saved Games 14132009 10:35 PR File folder
E Wideos Yideos 14132009 10:35 PRA - File folder
MTUSER.DAT.LOG 1172142010 1:33 Abd Text Docurment
1% windows 7 Base 64 MTUSER.DAT.LOGL 17272014 1157 PhA LGl File
‘?_f. Lacal Disk (C:) MTUSER.DAT.LOG2 I/13/2009 10:34 PR LOG2 File =
L# T on DITKA G| 1| L] | k
File narme: | [ETECTR | &dFiles -
[ Dpen ] [ Cancel ]
7. Enter a Key Name: DU
ﬁ Registry Editor EI@
File Edit ‘iew Favorites Help
4 (8 Computer Marne Type
o L HKEY_CLASSES ROOT ab| (D efault) REG_S7
oo L HKEY_CURRENT_LISER
b L HEEY_LOCAL MACHINE
a- | HEEY_USERS
il LT
P TETS-1E
» 5-1-5-14
e 5-1-5-20
ol 5-1-3-21-3510770625-4184624028-28T3166077-1000
el $-1-3-21-3510770625-4184624028-28T3166077-1000_Classes
b b $-1-3-21-3510770625- 41846 24028- 28 T3166077-300
oo 3-1-5-21-3510770625-4184624928-2873166077-500_Classes
++ 0 HEEY_CURREMT_COMFIG
« [ om P

Computer\HKEY_SERSN\DU

8. Navigate to: HKEY_USERS\DU\Software\MicrosofttWindows\CurrentVersion\Explorer\Shell Folders

You will probably see the path to the ProfileSetup account's original user profile directory saved in many of the values as

highlighted below. This can cause problems with programs which use these values. For example, a user may save a file to the
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Desktop from within a program, but the saved file doesn't appear on the user's desktop.

ﬁ Reqistry Editor EI@

File Edit Wiew Favorites Help

Speech || Mame Type Data &
S temericates ab{{Default | REG_5Z (value ot set)
WaB ab| 100 not use this .. REG_SZ UUse the SHGetFolderPath or SHGetknownFalderPath func
i msndows ab|{1B3EASDC-B58,., REG_SZ CiUsers\ProfileSetuph2ppDataiRoamingiMicrosofth\Wind
El | Currentversion a".'{3T4DE25|D—123F... REG_SZ CiUsers\ProfileSetuphDovwnloads
s B Bpplets a"l'{4C5C32FF—BBQ... REG_SZ CiUsers\ProfileSetuphSaved Games
a i Explorer i_'"_ {56734854-CaCB.. REG_SZ CiUsers\ProfileSetuph Contacts
: Advanced ab|fT0103404-DEB... REG_SZ Ci\Users\ProfileSetuphSearches
| ApplicationDestination: ab|fnn30A184-1780.., REG_SZ CiUsersiProfileSetupitppDatatl ocallow
| AutoplayHandlers ab|IBFBADSEN-CEA,,. REG_SZ Cihlsers\ProfileSetuphLinks
.. | BitBucket ab| Administrative T... REG_SZ CiUsersiProfileSetupiappDataiRoamingiMicrosofth\Wind
o CabinetState ab| appData REG_SZ Chllsers\ProfileSetupiAppDataiRoaming 3
; , CLEID _|[| =] Cache REG_SZ Cihlsers\Profile SetuptdppDatatLocalyhicro softivindoues
. Discardable =||| =8 co Burning REG_SZ Cilsers\ProfileSetupiy@ppDatatLocalyMicrosofthivindoues
- L HideDesktoplcans ab| Cookies REG_SZ Cillsers\ProfileSetupi®ppDatatRoaming\MicrosoftyWind
o LowiRegistry ab] Desktop REG ST CiillsersyProfileSetupiDesktap
>l MenuOrder ab| Favarites REG_SZ CUsers\ProfileSetupiFavarites
ikfadul s ab| Fonts REG_SZ CAWindows\Fants
i MountPoints2 ab| Histany REG_5Z ChUsersiProfileSetuphappDatatL ocalyhicrosofthifindow:
""" Lign shomea landler: ab|Lacal AppData REG_SZ CiUsers\ProfileSetupitppDatatlocal
; 2:::cn:EIZEfSorm 30| My Music REG_SZ CiUsershProfileSetupihusic
_____ 7 Shell Folders ab. Py Plictures REG_SZ C\Users\ProfileSetuphPictures
_____ : StariPage ﬁ'"_:M}f‘u‘ideo REG_SZ CiUsers\ProfileSetupiivideos
_____ | StartPage? ab| NetHood REG_SZ ChllserstProfileSetup2ppDatat Roaminghhicros oft\\Wind
o [ Strearns ab| Personal REG_SZ CiUsers\ProfileSetupiDocurments
_____ | StuckRects? al| PrintHood REG_SZ CiUsers\ProfileSetuph2ppDataiRoamingtMicrosofth\Wind
_____ Taskband = || 2B|Pragrams REG_5Z CUsers\ProfileSetuphappDatasRoamingihdicrosofty\Wind -
‘ I 3 ] m b

Compute A HKEY_UISERS\D N Software\Microsoft\WWind ows\CurrentiersionyExplorerShell Folders

9. Delete all of the values under Shell Folders except for (Default) and "!Do not use this registry key":

& Registry Editor EI@

File Edit Wiew Favorites Help

Speech * || Mame Type Data
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. ﬁAE a"‘é!Do not uze this registry key REG_5Z Use the SHGetFalderPath or SHGe
5

4. || Wrindows
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| AutoplayHandlers
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----- CabinetState
bl CLED

, Discardable

. HideDesktoplzons
----- LoweRegistry
5 - | MenuOrder

, Modules

, MountPaints2
----- MewshortcutHandlers
----- , RecentDaocs

m

: - =earchPlatform
..... J Shell Folders
..... StartPage

..... | StartPage?
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..... , HtuckRects2

i i G e Taskband i
] T b i« 1 b

Computer HEEY_USERS\D LN SoftwaretMicrosoft\Windows\CurrentWersiontExplorertShell Folders

10. Select the DU key in the left pane
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11. Click on the Edit menu and select Find...

12. Search the DU key for the string ProfileSetup. In general, you want to clean up everything that references the user named
ProfileSetup and the C:\Users\ProfileSetup directory. There will probably be several places under DU where these are saved.
You will need to analyze each match. Most matches won't cause problems. Some will such as the Shell Folders key you
previously cleaned up.

13. IMPORTANT: Unload the Default user registry hive:

a. Select the DU key
b. Click the File menu and select Unload hive...

Any new local user accounts created on the computer should receive a user profile configured with the customizations you made to the
Profile account.

Configure the User Account Picture (Optional)

1. Navigate to the directory: C:\ProgramData\Microsoft\User Account Pictures
(Note: you will need to enable "Show hidden files" to see this directory)
2. Rename user.bmp to something such as user-original.bmp
3. Copy the .bmp file you want used as the account picture to this directory and name it user.bmp

Force the Desktop Background to Appear on Windows 7 & Windows Server 2008 (Optional)

The following procedure should force a desktop wallpaper image to be displayed for all users regardless of whether or not the Desktop
Background option is selected in the .rdp file. This could be useful if you want a logo or an image containing instructions for the user to
always be displayed. There are some local group policy settings which can be configured to force a wallpaper to be shown and prevent
users from changing it. However, this only seems to work if the Desktop Background option is selected in the .rdp file.

You may encounter difficulty getting the wallpaper to be displayed under all situations. One known situation is when a user connects with
the Desktop Background option disabled. The wallpaper should be displayed initially. If the user disconnects from the remote computer
(but does not log out) and then reconnects, the wallpaper will probably not appear.

Run gpedit.msc

Navigate to User Configuration > Windows Settings > Scripts (Logon/Logoff)

Double-click Logon

Click Show Files...

The following directory should open: C:\Windows\System32\GroupPolicy\User\Scripts\Logon
Create a new text file with a .cmd extension in this directory

6. Add the following to the file:

o=

o

set WALLPAPER_PATH=%1

reg.exe ADD "HKEY_CURRENT_USER\Remote\2\Control Panel\Desktop" /v Wallpaper /d "%WALLPAPER_PATH%" /f
reg.exe ADD "HKEY_CURRENT_USER\Remote\2\Control Panel\Desktop" /v WallpaperStyle /d @ /f

reg.exe ADD "HKEY_CURRENT_USER\Control Panel\Desktop" /v Wallpaper /d "%WALLPAPER_PATH%" /f

reg.exe ADD "HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\General" /v
WallpaperSource /d "%WALLPAPER_PATH%" /f

7. Save the .cmd file
8. Click the Add... button on the Logon Properites pane:
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Logon Properties &Iﬁ
Scripts | PowerShell Scripts

>

= Logon Scripts for Local Computer

Mame Parameters

To view the script files stored in this Group Policy Object, press
the button below.

Show Files. . ]

ok [Comon ] (o

9. Click Browse...
10. Select the .cmd file and click Open
11. Enter the path to an image file in the Script Parameters box:

Add a Script [

Script Name:

set_wallpaper.cmd

Script Parameters:

C:A\Windows\Web\Wallpaper'Landscapestima 7 jpg|

| ok | [ cancel

12. Click OK twice
13. Close the Local Group Policy Editory
14. Run gpupdate.exe /force

Windows XP and Windows Server 2003

Create a Profile Configuration Account

1. While logged on as Administrator , create a local Windows user account named Profile and add it to the Administrators group
2. Configure the profile:

a. Log on as Profile

b. Make desired profile, desktop, and application changes
c. Log out

Copy the Customized Profile to "Default User"

1. Log back on as Administrator

2. Rename the C:\Documents and Settings\Default User directory to something like Default User Original
3. Open the Control Panel

4. Open System Properties

https://cwiki.apache.org/confluence/display/VCL/How+to+Configure+the+Windows+Default+ User+Profile

8/9



9/5/2015 How to Configure the Windows Default User Profile - Apache VCL - Apache Software Foundation

5. Select the Advanced tab

6. Click the Settings button next to User Profiles

7. Select Profile's profile, click Copy To :
Copy profile to: C:\\Documents and Settings\Default User
Permitted to use: add the Everyone group

8. Click OK

Clean up the Profile Configuration Account

1. Delete the Profile user
2. Delete C:\Documents and Settings\Profile

You can then create another account and log in using it to make sure your profile settings take affect for new users. Be sure to delete it
once you're done testing.
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